Пагинация

Люди, нажимаю на категорию — первые топики открываются нормально, нажимаю внизу на следующую страницу — вываливает такое http://sovunion.ru/category/pol/pol/page2/ и соответственно ошибка 404. Почему категория повторяется дважды? Кто нибудь знает как пофиксить? Alto 1.0.7 шаблон experience. Помогите пожалуйста пофиксить.

Похожие статьи

  • Не работает спойлер на страницах
    После обновления до версии 1.1.29, перестал работать спойлер на страницах, в топиках работает без проблем. А вот на страницах отображает просто текст. В чем может быть проблема ? Редактор: Tinymce P.S. Решил...
  • Ошибка авторизации через twitter
    Установил плагин «Плагин интеграции с соцсетями». Добавил ключи твитера: Consumer Key (API Key) и Consumer Secret (API Secret) и при авторизации ошибка Стойте! Маркёр запроса для этой страницы не действителен....
  • Ошибка в блогах
    После установки версии 1.1.28, ни чего не меняя, кликаем на меню «Блоги» и появляется ошибка: Parse error: syntax error, unexpected '[' in W:\home\smylife.ru\www\common\classes\actions\ActionBlogs.class.php...
  • Ошибка System error #1002 помогите
    Перенес сайт на хостинг с локального Denwer, при заходе на главную страницу появляется ошибка System error #1002, при этом в виджете прямой эфир идет постоянно загрузка, в админку не входит.Как исправить подскажите...

4 комментария

0
Похоже на баг.
У себя решил изменением сроки 133 в файле plugins/categories/classes/actions/ActionCategory.class.php
rtrim($oCategory->getUrl(), '/')

на
Router::GetPath('category') . ($oCategory->getUrl())

Просто прописал логический путь для формируемой ссылки, но — не факт, что это решение идеально. Лучше подождать, что скажут разработчики.
0
При переходе по страницам страница не меняется а УРЛ постоянно растет до типа такого:
sovunion.ru/category/pol/page2/pol/page4/pol/page6/pol/page9/

Пока сделал как у Вас, может разработчики пофиксят как нужно.
Отредактирован:
+2
Да, есть ошибка в плагине Категории. Там вместо rtrim($oCategory->getUrl(), '/') должно быть $oCategory->getLink()
0
Спасибо, теперь нормально работает.
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.