Вопрос о меню и его структуре

Всем привет, давно уже слежу как за лайвстритом, так и за альто и вот зашел в альто в тупик с меню. Вопрос такой, как изменить структуру кода меню, точнее в каких файлах генерируется сетка и где можно заменить теги ul,li и т.д. на span, div и т.п. и т.д.? Где заменить тег уже узнал, а вот где находятся внутренние теги, вот это загадка.

Новый журнальный шаблон «TREND»

Привет, уважаемое сообщество AltoCMS!
Хочу Вас порадовать появлением на этой CMSки еще одного шаблона с названием TREND.
Шаблон отлично (на мой взгляд) зарекомендовал себя на LiveStreet CMS, я очень хотел его сделать и на AltoCMS, однако по разным причинам время затягивалось, и наконец-то это свершилось!
Не буду много писать о шаблоне, поскольку на LS посвящен отдельный топик этому шаблону, в котором приличное количество сообщений.


Читать дальше →

Ошибка в плагине «Гостевые комментарии»

Устанавливаю плагин «Гостевые комментарии», побывал разные версии: из каталога 1.1.9 и с гитхаба 1.1.10 на AltoCMS 1.1.29

В настройках указываю обязательный email адрес, нажимаю сохранить и вылетает такая ошибка

Fatal error: Call to a member function getMail() on null in mysite.ru\common\plugins\gc\classes\actions\ActionAdmin.class.php on line 124

E_ERROR [1] Call to a member function getMail() on null
See details in error.log


ActionAdmin.class.php on line 124


// Проверяем email
            if (($sEmail = getRequestStr('admin_social_email')) && F::CheckVal($sEmail, 'mail') && (!E::Module('User')->GetUserByMail($sEmail) || $sEmail == $oGuestUser->getMail())) {


В логах

E_ERROR [1] Call to a member function getMail() on null (mysite.ru\common\plugins\gc\classes\actions\ActionAdmin.class.php on line 124)
2018-01-30 01:08:45

E_USER_WARNING [512] Can not prepare asset file "mysite.ru/common/plugins/gc/templates/skin/default/assets/css/plugin.gc.css" (F:\Web\OpenServer\domains\sm.ru\engine\classes\modules\viewerasset\entity\Package.entity.class.php on line 169)
2018-01-30 01:08:45

E_USER_WARNING [512] Can not prepare asset file "mysite.ru/common/plugins/gc/templates/skin/default/assets/css/plugin.gc.css" ( mysite.ru\engine\classes\modules\viewerasset\entity\PackageCss.entity.class.php on line 186)

Как скрыть блог от индекса

Всем привет!
Дано: блог со статьями, в настройках использую стандартную ссылку site/blog/name-blog/default.html
Если указать в robots.txt Disallow: /blog/name-blog/, то страницы site/blog/name-blog/default.html все равно остаются в индексе.
Вопрос: как скрыть все статьи блога из индекса?
Спасибо!

Не работает плагин

Установил плагин от LS «Публикация от чужого имени» github

В комментариях плагин работает, а вот при создании / редактирования топика не работает, даже форма не отображается с выбором пользователя.

На предыдущих версиях Altocms работал без проблем, а AltoCMS 1.1.29 не работает с топиками. Ни как не могу понять где и что нужно изменить в плагине.

P.S. Готов заплатить за адаптацию плагина, под AltoCMS 1.1.29

шаблоны alto

скажите, а вообще есть люди которые делают шалоны под данную цмс, проекту есть будущее?) если бы мне обьяснили или дали какой-то настройщик шаблонизатор, я бы мог делать что-то

Ошибка в файле Mresource.entity.class.php

В журнале постоянно появляются данная ошибка:

018-01-02 20:01:38
E_NOTICE [8] Uninitialized string offset: 0 (/var/www/admin/www/mysite.ru/common/classes/modules/mresource/entity/Mresource.entity.class.php on line 134)
2018-01-02 20:01:22
E_NOTICE [8] Uninitialized string offset: 0 (/var/www/admin/www/mysite.ru/common/classes/modules/mresource/entity/Mresource.entity.class.php on line 134)
2017-12-30 15:03:28
E_NOTICE [8] Uninitialized string offset: 0 (/var/www/admin/www/mysite.ru/common/classes/modules/mresource/entity/Mresource.entity.class.php on line 134)


Версия AltoCMS 1.1.29

Вот это строка в файле Mresource.entity.class.php

134  if ($sUrl[0] === '@') {


В чем проблема ? И как это можно исправить ?

Как добавить изображения в Alto cms?

Привет!

Не смог найти в поиске ответа по этому вопросу. Хочется грузить картинки на сервер и оттуда отгружать, и после добавления к записи изображений они просто не добавляются.

В меню редактирования есть такая добавка: Вставить фотосет и после нее в текст добавляется
Но картинка все так же не добавляется.

Как грузить изображения на сервер и добавлять их в записи?

Ошибка при включенной стандартной рейтинговой системе. Значение сила постоянно 0.00

Всем доброго времени суток.
При включенной стандартной рейтинговой системе, когда плюсуешь (минусуешь)какой-то топик в логе появляется вот такая ошибка:
E_NOTICE [8] Undefined variable: iCountRange (/var/www/serv19/data/www/uс/common/plugins/rating/classes/modules/rating/Rating.class.php on line 150)

и такая:

E_NOTICE [8] Undefined variable: iMinCount (/var/www/serv19/data/www/uс/common/plugins/rating/classes/modules/rating/Rating.class.php on line 150)

При включенной упрощенной рейтинговой системе ошибки отсутствуют.
Так же не зависимо от изменения рейтинга сила равна 0.
Подскажите куда копать или что я делаю не так.
Заранее спасибо за помощь.
Версия Альто — 1.1.29 (2017-04-23)