Обновление плагина Alian для AltoCMS версий 0.7 - 0.9.7.1

Обновился плагин Alian для текущей версии AltoCMS. В новой версии решено было отказаться от flash-загрузчика. Для загрузки файлов применен HTML5 File API, что позволяет использовать плагин на тех системах, где технологии Adobe Flash использовать затруднительно, например на некоторых мобильных устройствах. AlianВы можете выбрать файлы на компьютере обычным образом, используя кнопку Обзор, а можете просто перетащить их в область загрузки с рабочего стола или из вашей папки с картинками.
Добавлен функционал в виджете.
Теперь три основные кнопки (вставить, вставить превью и удалить) — находятся сверху миниатюрки,
а внизу находятся кнопки для вставки изображения с позиционированием по центру, справа или слева. Ранее для этого использовалось дополнительное всплывающее окно, теперь достаточно кликнуть на нужной кнопки.
Добавлен функционал расширенного отображения ошибок при загрузке файлов в стандартных всплывающих подсказках системы, также упрощен и обновлен JS код плагина.
Более подробное описание плагина читайте в предыдущей статье — http://altocms.ru/blog/extensions/320.html

Готова версия плагина и для новой AltoCMS версии 1.0
В этом варианте плагина, для новой версии Alto, полностью разделены фотосет и функционал плагина. Для загрузки фото и картинок, хранения информации о них и для работы с ними — плагин использует только свой функционал, что позволяет иметь два независимых варианта работы с фото и картинками. Можно использовать фотосет и при этом работать с плагином. Все изображения используемые фотосетом и плагином полностью независимы. Сейчас я тестирую эту версию и скоро состоится релиз и этого плагина.

12 комментариев

+1
Опечатка в заголовке?
+1
Никаких опечаток, это плагин для версий Alto начиная с версии 0.7 до 0.9.7.1 включительно. Для версии Alto 1.0 — он не подойдет. Его опубликую чуть позже.
+1
Но решил все же поправить, а то не совсем понятно получается. Спасибо.
0
Да, я как-то посчитал, что 0.7+ априори исключает 0.8 и т.д. :)
Спасибо.
Спасибо Вам!
0
Здравствуйте. Если я приобрету эту версию плагина, а потом перейду на 1.0, нужно будет заново покупать или Вы вышлите новую версию?
0
Здравствуйте. Версии для старого и нового поколений Alto будут разными и в каталоге они будут представлены отдельно, так как не совместимы между собой. Сейчас в каталоге нет такого функционала, что бы можно было выложить две разных версии по одной цене, но я буду высылать плагин людям по запросу, если им понадобится плагин для новой Alto 1.0
0
Спасибо. Тогда на днях приобрету.
0
Как приобретете — напишите мне в л.с. свой e-mail и я вышлю вам версию для 1.0
+1
Можно в архив положить две версии
+2
В архив две версии нельзя, так как архив должен устанавливаться через админку CMS и там должна быть одна папка с плагином. (требование магазина плагинов и самой CMS, я с ними согласен).
Но есть вариант — при покупке плагина, клиенту доступны обе версии, которые он может скачать, и в дальнейшем получать обновления, без лишних телодвижений.
Сейчас с моим плагином так и есть.
Спасибо за ваш комментарий, ибо это не очень ясный момент был.
Отредактирован:
+1
И да, я по началу не знал, что так можно, ибо не был знаком с механизмом публикации плагинов.
Я знаю, что теперь есть два топика которые я создал про один плагин, но это два разных плагина, один от другого отличается кардинально.
Каждый из плагинов (представленные в одном пакете) будут обновляться и совершенствоваться независимо друг от друга, но продаваться по одной цене за все версии.
Отредактирован:
+1
А можно ли добавить кнопку «Вставить все изображения» и все изображения вставляются с тегом br?
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.