Hacking attempt!

Добрый день

Установил последнюю версию altocms. Перед установкой переименовал файл config.local.php.dist. memcache не устанавливал еще. При попытке удалить топик или выполнить выход получаю ошибку: Hacking attempt! Пробовал под разными браузерами, но ошибка одна и та же. Что я делаю не так? :) Что необходимо поправить или в какую сторону смотреть?

Похожие статьи

  • Не работает спойлер на страницах
    После обновления до версии 1.1.29, перестал работать спойлер на страницах, в топиках работает без проблем. А вот на страницах отображает просто текст. В чем может быть проблема ? Редактор: Tinymce P.S. Решил...
  • Ошибка авторизации через twitter
    Установил плагин «Плагин интеграции с соцсетями». Добавил ключи твитера: Consumer Key (API Key) и Consumer Secret (API Secret) и при авторизации ошибка Стойте! Маркёр запроса для этой страницы не действителен....
  • Ошибка в блогах
    После установки версии 1.1.28, ни чего не меняя, кликаем на меню «Блоги» и появляется ошибка: Parse error: syntax error, unexpected '[' in W:\home\smylife.ru\www\common\classes\actions\ActionBlogs.class.php...
  • Ошибка System error #1002 помогите
    Перенес сайт на хостинг с локального Denwer, при заходе на главную страницу появляется ошибка System error #1002, при этом в виджете прямой эфир идет постоянно загрузка, в админку не входит.Как исправить подскажите...

14 комментариев

0
Установка чистая или переход с LS?
0
Установка чистая. Плагинов тоже никаких не ставил.
0
Первое, что приходит в голову — вы изменяли значения $config['security']['salt_...'] в Config-e после установки?

P.S. Эта «соль» используется для формирования и сверки пароля, идентификаци сессии по $_COOKIES[user_key] и безопасной навигации по $_SESSION[ALTO_SECURITY_KEY]
0
Нет, ничего не менял. А какие значения должны быть?
0
Alto сама устанавливает случайные значения этих строк в config-e…
0
Ну тогда дело не в этом. Конфиги ручками никакие не правил.
0
Проверьте наличие $_COOKIES[user_key] и $_SESSION[ALTO_SECURITY_KEY] после входа в Alto…
0
Где это проверить?
0
Создайте в директории ALTO php скрипт, пусть он сделает вам print_r($_SESSION) и print_r($_COOKIE), только не забудьте open_session();
0
А установку как выполняли? Через /install или все руками?
0
Через /install
0
Удалось воспроизвести?
+1
Была похожая проблема. Отпишу, как с ней справился. Может кому пригодится. Извиняюсь, если решение уже где-то описано в сообществе (я не нашел).

Проблема возникла при адаптации стороннего шаблона для LiveStreet. Всё работало исправно, кроме удаления статей и кнопки «Выход». Первое, что обратило на себя внимание, — это полупустая строка браузера:
/?security_ls_key=

— а именно, отсутствие самого ключа. К конфигурационному файлу, как и ТС, я не прикасался и сгенерированные ключи в нем присутствовали. Оставалось понять, почему движок не может их прочитать. В Альто за вывод ключа отвечает данная функция:
{$ALTO_SECURITY_KEY}

— и соответствующие файлы шаблона. Включив логику, я понял, что где-то пропустил родное для шаблонов LS значение функции:
{$LIVESTREET_SECURITY_KEY}

Чтобы не перелопачивать все файлы шаблона по одному, я воспользовался Total Commander-ом. В поиск по файлам «С текстом» забил значение LS «LIVESTREET» и..., о позор, таких файлов нашлось аж 12 штук. В том числе и отвечающих за те же удаление статьи (в topic_part_header.tpl):
{router page='content'}delete/{$oTopic->getId()}/?security_ls_key={$ALTO_SECURITY_KEY}

— и «Выход» (в header_top.tpl):
{router page='login'}exit/?security_ls_key={$LIVESTREET_SECURITY_KEY}

Исправление данного недоразумения устранило и проблему.
Отредактирован:
0
Ребята, столкнулся с этой проблемой. Кто решил? При удалении статей и при выходе получаю это же сообщение. Система чистая.
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.