Плагин DAO и AltoCMS 1.0

Уважаемые разработчики, мой вопрос очень короткий: плагины линейки DAO совместимы с последней версией Alto?
Если нет, то каковы перспективы? Спасибо.

P.S.: Поздравляю с Праздником всех, кто чтит этот священный день.

Похожие статьи

  • Обновление линейки DAO
    Приветствую. Рад сообщить о вышедшем обновлении линейки DAO (4в1, маркет, компании). Что изменилось и добавилось: 1) Доработки карты: — фильтры в карте (по категориям и по дополнительным полям), — возможность...
  • Версия 1.1.23 — небольшие исправления и чуть-чуть новенького
    Таки вышел релиз Alto CMS 1.1.23. Каких-то «прорывных» фишек в ней нет, она, главным образом, исправляет ряд обнаруженных ошибок и чуть-чуть добавляет некоторых новых возможностей для разработчиков. Вот список...
  • Как обновить сайт на Alto CMS 1.1.x
    Подготовка к обновлению Этот шаг не обязательный, но желательный, если вы его еще не делали — скопировать файлы конфигурации сайта и все файлы конфигурации всех плагинов и скинов в папку /app вашего сайта. Если вы...
  • Alto CMS 1.1.х и плагины DAO
    Вот уже больше полугода как функционирует ветка Альто 1.1.х, многие следят за ней и с нетерпением ждут развития. Но и столько же тянется проблема работы с ней плагинов DAO..

17 комментариев

+1
Адаптация под alto 1.0 будет через некоторое время после выхода alto. Следите за обновлениями.
0
Спасибо. Будем ждать.
+2
DAO 4 в одном не адаптирован под experience да и start-kit тоже. Когда планируется адаптация?
0
А у Вас активация плагина нормально прошла? Какая версия DAO устанавливалась?
0
DAO последнюю версию ставил. С активацией проблем не было, лицензию закинул в корень плагина + прописал в конфиге buy_code и config_code.
0
И всё таки, у кого-то получилось установить DAO на последний релиз движка? Здесь же работает, как видим… У меня не получилось.
+1
С дев версией 1.0.8 ДАО в общем то заработали, только на шаблонах от LS. На шаблонах из коробки Альто, есть проблемки… Ну и что-то Компании не хотят нормально работать.
А так ждем релиз 1.0.8, т.к. Вадим обещал, что ДАО с ней заработает:
Начну с планов ближайших. А в них значится выпуск версии 1.0.8. Ключевая задача релиза — решение проблем, связанных с совместимостью плагинов, написанных под ЛС 1.0.+ (в частности, отшлифовываются нюансы совместимости с плагином DAO).
+1
На шаблонах из коробки Альто, есть проблемки…
Проблемки на уровне верстки и CSS-классов, но программных ошибок нет, верно?

Ну и что-то Компании не хотят нормально работать
А с ними что? Сыплются ошибки или тоже просто отображаются криво?
0
Проблемки на уровне верстки и CSS-классов, но программных ошибок нет, верно?
Утверждать не могу, но похоже на НЕ адаптированность шаблонов.

А с ними что? Сыплются ошибки или тоже просто отображаются криво?
Встретил ошибку БД…
Например, включение ДАО Компаний, при внесении в данный раздел хотя бы одной Компании выдает такую ошибку:

SQL Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND t.blog_id=b.blog_id' at line 9 at /var/www/protiv-ugona/data/www/pw.protiv-ugona.ru/common/classes/modules/topic/mapper/Topic.mapper.class.php line 376 — Array ( [code] => 1064 [message] => You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND t.blog_id=b.blog_id' at line 9 [query] => SELECT count(t.topic_id) as count FROM pw_topic as t, pw_blog as b WHERE 1=1 AND (t.topic_publish = 1) AND (t.topic_date_show IS NULL OR t.topic_date_show <= '2014-09-29 10:08:39') AND ((t.topic_date_show IS NOT NULL AND t.topic_date_show >= '2014-09-28 10:00:00' AND t.topic_date_show <='2014-09-29 10:08:39') OR (t.topic_date_show IS NULL AND t.topic_date_add >= '2014-09-28 10:00:00')) AND (b.blog_type='close' AND t.blog_id IN ('2')) OR (b.blog_type IN ('open','dao'))) AND t.blog_id=b.blog_id; [context] => /var/www/protiv-ugona/data/www/pw.protiv-ugona.ru/common/classes/modules/topic/mapper/Topic.mapper.class.php line 376 )

Причем эта ошибка только на главной. На других страницах она не появляется.
+1
Ну тут и правда ошибка в запросе. Там не хватает одной открывающей скобки перед b.blog_type='close'
0
Вот такая ошибка после активации плагина:

E_WARNING [2] PluginDao_ModuleCatalog::getcd(../site.ru/engine//lib/external/XXTEA/encrypt.php): failed to open stream: Нет такого файла или каталога

See details in error.log

Fatal error: PluginDao_ModuleCatalog::getcd(): Failed opening required '../site.ru/engine//lib/external/XXTEA/encrypt.php' (include_path='.:/usr/local/zend-5.4/share/pear:/../site.ru/engine/classes/core:/../site.ru/engine/classes/abstract:/../site.ru/engine/classes/core') in ../site.ru/common/plugins/dao/classes/modules/catalog/Catalog.class.php on line 0

E_COMPILE_ERROR [64] PluginDao_ModuleCatalog::getcd(): Failed opening required '../site.ru/engine//lib/external/XXTEA/encrypt.php' (include_path='.:/usr/local/zend-5.4/share/pear:../site.ru/engine/classes/core:../site.ru/engine/classes/abstract:../site.ru/engine/classes/core')

See details in error.log
+2
Как видно из каталога под Новый год незаметно обновилась линейка DAO до совместимости с Альто 1.0+ Ура товарищи!
0
И что? У Вас получилось поставить DAO?
0
Ставьте на 1.0.8 — 3.6.4alto версию с плагином совместимости и все будет работать.
0
… с плагином совместимости...
Здравствуйте!
Да, точно. Совсем об этом не подумал.
Все работает, но вот при добавлении видео вылетает такая ошибка:
Fatal error: Class 'ModuleImage' not found in site.ru/common/plugins/dao/classes/modules/catalog/Catalog.class.php on line 0

E_ERROR [1] Class 'ModuleImage' not found
See details in error.log

Не подскажите, что делать?
+1
Ставьте на 1.0.8

Почему 1.0.8? тех пор очень много было исправлено.
0
Думаю пойдет и на 1.1, но без напильника не обойтись.

Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.