Совместимость с шаблонами LS 1.0.3

Всем привет!
Скажите пожалуйста такую вещь. У меня есть довольно таки дорогой шаблон для Livestreet 1.0.3 и я планирую переход на Alto. Насколько совместимы шаблоны и насколько сложно будет его переделывать под новую цмс?

Спасибо :)

Похожие статьи


4 комментария

+2
Адаптация шаблона будет состоять из двух частей:

1) Небольшие изменения шаблона, чтобы он запустился так же, как он работает сейчас под ЛС. Изменения эти действительно совсем небольшие, есть даже черновик краткой инструкции, что именно нужно сделать.

2) Изменения, которые связаны с дополнительным (по сравнению с ЛС) функционалом. Например, редактирование комментариев, и т.д. Т.е. шаблон работать будет и без этих изменений, только некоторые чисто альтовские функции могут быть недоступны.

А в целом особых сложностей быть не должно
+1
Вот как можно сделать «инструкцию» по адаптации шаблона:
— скачиваем программу для сравнения файлов, например эту
— сравниваем папку synio из LS и из Alto
— получаем «инструкцию»
0
Вэй из мир! Зачем такие заморочки? Проект фреймворка живет на гитхабе, учите людей правильным вещам: git умеет diff и патч. Есть гуевые обвесы и под никсы и под макось и даже венды. Все это можно делать с версионированием и ветвлением.

ЗЫ Видели бы вы на чем еще можно вести разработку и какими средствами — ахнули бы ;-) Я например ненедко это делаю на айпаде в положении вверх ногами… :)
Отредактирован:
0
Спасибо парни!
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.